6 posts :: Page 1 of 1
By: Likes:
  (Read 509 times)  

On one of our websites people not have to login to post on the forum, but with glFusion release 1.30 all users get the message that they post spam. I tried it myself and it's true...

Everything is considered spam...

   
Active Member
glFusion User
Registered: 07/29/08
Posts: 551
Location: Bangkok, Thailand
By: Likes:
   

Seems that I found the problem, in our SPAM-X we have ".ru" on the list of spam. With glFusion 1.22pl4 that was no problem, but it seems that version 1.30pl0 overlooks the dot in the front of the "ru"... and blocks everything what has "ru" in it....

php Formatted Code
Thu 08 Aug 2013 11:09:52 UTC - Found Spam Post matching .ru posted by user 1 from IP 125.24.88.107

Seems that the word "Structure" in a regular line is the problem in this case. The Forum post has no URLs or anything else that could tricker the spam filter...

   
Active Member
glFusion User
Registered: 07/29/08
Posts: 551
Location: Bangkok, Thailand
By: Likes:
   

I haven't checked, but perhaps escaping the dot might narrow it down. Try "\.ru" in your spam list to see if it only catches posts with those characters.

   
Admin
glFusion Developer
Registered: 06/10/08
Posts: 2265
By: Likes:
   

He Lee,

Doing "\.ru" is the same as not having it in the SPAM-X list. Everybody with a Russian domain name can spam our website...

   
Active Member
glFusion User
Registered: 07/29/08
Posts: 551
Location: Bangkok, Thailand
By: Likes:
   

Me too. I have tried posting while logged in. I am trying it without logging in for this post. Let's see if it works.

Guest User
By: Likes:
   

It appears it is the Akismet module that is detecting the spam. I've disabled it for now, will do a little debugging to figure out why it thinks your posts are spam. For now, you should be good to go.

   
Admin
glFusion Developer
Registered: 10/21/05
Posts: 7462
Location: The Great State of
Texas
6 posts :: Page 1 of 1