4 posts :: Page 1 of 1
By: Likes:
  (Read 80 times)  

If I login and try to make a post in the forums I get the message "Your post has been identified as a spam message". If I logout I can post in the forums.

Guest User
grumpy
By: Likes:
   

I even enabled Two Factor Authentication and still get the same spam message.

Guest User
By: Likes:
   

Give it another shot - I've disabled the Akismet module for now - I noticed you are coming in on an IPv6 address - not sure if that has anything to do with it or not. Checking into it.

   
Admin
glFusion Developer
Registered: 10/21/05
Posts: 7462
Location: The Great State of
Texas
By: Likes:
   

I've been doing a little testing to determine why your posts were marked as spam. Here is what I've come up with (and a little history....)

glFusion DOT org uses 2 external services for spam filtering
- Stop Forum Spam
- Akismet

Akismet was flagging your posts as spam based on your email address (the one associated to your user account here).

I have run the domain for your user email through all the Realtime Blacklist checks I can find and get 0 (zero) hits - so I don't know why Akismet is flagging your email. Here is the response we get from Akismet:

php Formatted Code
Array
(
    [0] => HTTP/1.1 200 OK
Server: nginx
Date: Mon, 11 Jun 2018 16:59:17 GMT
Content-Type: text/plain; charset=utf-8
Content-Length: 4
Connection: close
X-akismet-guid: 85026b70562350a94d6cdcd051df0a78
    [1] => true
)

As you can see - they don't give much to go on.

What I've done is written an interactive form that allows me to emulate a post - so username, email, post content, IP, referer, useragent. Using your post above as a sample, using both the IPv6 and IPv4 address, with your user agent (from GUS), Akismet always returns TRUE when using your email. If I change the email, it returns false with your IP, usernamet, etc. Stop Forum Spam does not flag anything using your info....

So far, I'm not having any luck getting additional details on why they (Akismet) doesn't like your email address. Specifically, it appears to always return TRUE (spam) for any email I try from your domain.

So - my best advice right now is to try contacting Akismet directly (https://akismet.com/contact/) - but from what I'm seeing through my Google searches, it doesn't sound like this will bear much fruit.

I have disabled the Akismet for now. Honestly, it really isn't needed - glFusion has other spam blocking capabilities that are working just fine and so far are blocking 100% of the comment, forum, registration spam attempts we're seeing (BTW - without CAPTCHA, we don't use it here anymore either and haven't for a while now). Akismet was just another extra layer of protection, but if it is blocking valid users, I would rather raise my risk on having a couple of spam messages compared to blocking one valid one.

Thanks!
Mark



   
Admin
glFusion Developer
Registered: 10/21/05
Posts: 7462
Location: The Great State of
Texas
4 posts :: Page 1 of 1