By: Anonymous: blanch80 ()  Apr 06 2011 07:46 am (Read 1208 times)  


Apologies if this has already been covered but I have tried the search function and came back with nothing.

When downloading Office 2010 formatted documents (.docx / .xlsx etc...) they are downloading as zip file with folders & xml files inside. I've looked to change the allowable file formats in the site configuration but the only place i could see this was within forum attachements.

Could someone please advice, whether Office 2010 documents are able to be stored within glFusion and if so how i can allow the file file extensions to be uploaded?

I've tested multiple documents with the same issue, and saved the documents as 2003 format and they have uploaded and are downloadable as expected.


By: Mark (offline)  Apr 06 2011 09:08 am  

The FileMgmt plugin doesn't do any post processing on a file, it simply takes what you uploaded and stores it in the repository. I've done a few quick tests where I've uploaded both a .docx and .xlsx file and they are downloading fine (on my dev box).

If you could email me a .docx and .xlsx file that are not working for you, I'll be happy to use those on my test system and see if I can find any reason why it isn't working. My email is mark AT glfusion DOT org.


glFusion - Enhanced Content Management



Group Comfort
: +112
Registered:: 10/21/05

Posts: 6602
By: lgarner (offline)  Apr 06 2011 09:18 am  

It sounds like the browser might not have the document type associated with MS Office. If you download and save the file, it should still have the "docx" extension and be able to be opened by Office.

I suspect that the browser doesn't know what the file is, so it's just guessing at the application to use. Since these files are actually zip files containing XML (hence "docx" instead of "doc"), it just treats it as a zip.




Group Comfort
: +52
Registered:: 06/10/08

Posts: 1958
By: André (offline)  Apr 06 2011 12:14 pm  

The new formats of Office are in fact archive files.
It is useful to check the operating system.

Input in console cmd.exe:
for /f "delims== usebackq tokens=1,2*" %a in (`assoc .xlsx`) do @echo %a & @ftype %b
the result:
Excel.Sheet.13="Path to EXCEL.EXE" /e

Office 2007 is version 12.
How does a different browser?

good luck



Group Comfort
: +2
Registered:: 03/30/11

Posts: 49
By: Anonymous: blanch80 ()  Apr 06 2011 13:57 pm  

Thanks for the replies everyone.

It's really odd after more testing.

I can upload the same .docx file to my main site, a test site and a local install. The document downloads fine on the test site and the local install so it points to a problem with the site config itself.

However, I can successfully download these documents from all sites (including the main problem site) with no problem using Chrome.

It seems to be pointing to an issue with IE & the site itself?!?!?! I can't think of any configuration changes that I've made?

The only thing i can think of that is different is that in the main site the 'Public' files aren't installed in a Public_html folder but are in the root directory (along with the private directory). Could that be an issue do you think?

I've tested this logged in as admin and a normal logged in user. I have also reset my IE's settings to no avail.

All your help is greatly appreciated!


By: Anonymous: mst3kroqs ()  Apr 07 2011 09:18 am  

Hi -

Any chance you are using a proxy to get to the main site, but not to the test site or local install? Sometimes proxy servers can mangle the content-type in the response header ...

By: Anonymous: blanch80 ()  Apr 08 2011 03:50 am  


I am going through a proxy - but for all 3 sites so there should be no difference.

I've also tried access without going through a proxy but get the same problem.

I'm just hoping i don't have to flatten and re-build the site....

7 posts :: Page 1 of 1