By: Goofy (offline)  Mar 09 10 @ 4:34  (Read 2937 times)  

Can you tell me where to change the background in fckeditor.
You can see on this site under Kontakt that the main background color #000000 does show in the editor textarea and its the same color as the text.
eurotour5000.dk/cms/profiles.php?uid=2

Thanks
Goofy


Thanks
Goofy

   
Forum Chatty
Chatty

Goofy



Group Comfort
Level:
: +1
Registered:: 02/24/10
Posts: 40
Location: Denmark
By: Geiss (offline)  Mar 09 10 @ 9:02   

Have a look in public_html/fckeditor/editor/css/fck_editorarea.css. You'll want to adjust the body selector below to your liking:

PHP Formatted Code
body
{
        background-color: #ffffff;
        padding: 5px 5px 5px 5px;
        margin: 0px;
}



Make sure to clear your browser cache. Wink

Thx!

Eric

   
Forum Active Member
Active Member

Geiss



Group Comfort
Level:
: +58
Registered:: 02/15/07
Posts: 2097
Location: Boise, Idaho
By: Mark (offline)  Mar 09 10 @ 9:05   

The editor's colors are inherited form the body style. Try this in your style.css and let's see if makes a difference:

PHP Formatted Code

body {
background:#FF0000;
font:76% arial,verdana,tahoma,helvetica,sans-serif;
text-align:left;
margin:0;
padding:0;
color: #FFFFFF !important;/*UKJ HVID TEKST*/
}
 


Notice I added the !important after the color:#FFFFF

One thing I've noticed when trying to adjust the FCKeditor styles, it really likes to cache stuff. So, after making the change, go into glFusion's Command & Control and select Clear Cache. Then, clear your browsers cache and restart the browser to ensure it is loading everything new.

Let me know if this helps.

Thanks!
Mark


Join me on the glFusion Gitter Channel

   
Forum Admin
Admin

Mark



Group Comfort
Level:
: +113
Registered:: 10/21/05
Posts: 7401
Location: The Great State of
Texas
By: Goofy (offline)  Mar 09 10 @ 9:29   

Hi and thanks,

I got it here :-)


\fckeditor\fckconfig.js

FCKConfig.EditorAreaStyles = 'body { color:#000;margin-bottom:30px;}

Change to:

FCKConfig.EditorAreaStyles = 'body { background-color:#ffffff; color:#000;margin-bottom:30px;}

Thanks
Goofy


Thanks
Goofy

   
Forum Chatty
Chatty

Goofy



Group Comfort
Level:
: +1
Registered:: 02/24/10
Posts: 40
Location: Denmark
By: Anonymous: Ero ()  Mar 10 10 @ 12:44   

Hmmm how to solve this (see image).

These are the changes I´ve made to the style.css (I´ll be happy to get the correct answer where to put this to skip !important witch I think is the problem here)

style.css

PHP Formatted Code
body {
background:#red;
font:76% arial,verdana,tahoma,helvetica,sans-serif;
text-align:left;
margin:0;
padding:0;
}
 
   To:
 
body {
background-color:black !important;
background:url(layout/fESTIHOUSe/images/bg.png) 0 0 !important;
background-repeat:repeat-x !important;
background-attachment:fixed !important;
background-position:top !important;
font:76% arial,verdana,tahoma,helvetica,sans-serif;
text-align:left;
margin:0;
padding:0;
}



Know I can put all the background info on one row, want it like this for now for a better overview Smile

By: Mark (offline)  Mar 10 10 @ 12:48   

Just to make sure I understand what you want to accomplish....You want to have an image as the page background, but have a standard white background with black text for the editor?

Thanks!
Mark


Join me on the glFusion Gitter Channel

   
Forum Admin
Admin

Mark



Group Comfort
Level:
: +113
Registered:: 10/21/05
Posts: 7401
Location: The Great State of
Texas
By: Anonymous: Ero ()  Mar 10 10 @ 1:26   

Exactly! Smile

By: Mark (offline)  Mar 10 10 @ 1:34   

What I would do is this:

Create a custom htmlheader.thtml template and specify your background image there on the body tag:

HTML Formatted Code

<body style="background:url({site_url}/ayout/fESTIHOUSe/images/bg.png) 0 0;">
 


Change your style.css back to the default settings and I think you should be good to go.

Thanks!
Mark


Join me on the glFusion Gitter Channel

   
Forum Admin
Admin

Mark



Group Comfort
Level:
: +113
Registered:: 10/21/05
Posts: 7401
Location: The Great State of
Texas
By: Anonymous: Ero ()  Mar 10 10 @ 1:51   

Worked like a charm! Thanks alot!

Just a notice; You forgot the l in layout

PHP Formatted Code
<body style="background:url({site_url}/layout/fESTIHOUSe/images/bg.png) 0 0;">



If someone else want to fix this Smile

This is my code for all the above:

PHP Formatted Code
<body dir="{direction}" style="background:url({site_url}/layout/fESTIHOUSe/images/bg.png) repeat-x fixed top;">



I creating a "new" theme base on novaeu, so there is no need for custom for me Smile

If you got Skype I would like to add you Smile My screeen name is "Dannan" or what you call it Smile

9 posts :: Page 1 of 1