By: Anonymous: alett ()  Jan 14 2009 13:26 pm (Read 1141 times)  

I am trying to upload a logo (logo size 100pix high .png file) to my site, through the Command&Control, Logo function but get the following error:

An error has occurred:
2 - move_uploaded_file(/srv/www/virtual/nameofmysite.com/htdocs/images/logo6328bef8.png) [function.move-uploaded-file]: failed to open stream: Permission denied @ /srv/www/virtual/nameofmysite.com/htdocs/admin/plugins/sitetailor/logo.php line 126

How can I fix this?
-Alett

By: Geiss (offline)  Jan 14 2009 13:37 pm  

Hi alett,

Line 126 in logo.php is:

PHP Formatted Code
                $rc = move_uploaded_file($file['tmp_name'], $_CONF['path_html'] . 'images/' . $newlogoname);



which refers to moving the image from the temp directory to the public_html/images/ directory. Make sure that the permissions are set so that the user the webserver runs as can write to the public_html/images/ directory.

Thx!

Eric


Geiss



Group Comfort
Level:
: +58
Registered:: 02/15/07

Posts: 2097
By: Anonymous: alett ()  Jan 14 2009 13:48 pm  

Eric,
See if I understand correctly. I need to set write acces to folder public/images?

-a

By: Geiss (offline)  Jan 14 2009 13:51 pm  

I need to set write acces to folder public/images?



Yes. Not for everyone, but just for the account that the webserver runs as. Big Grin

Thx!

Eric


Geiss



Group Comfort
Level:
: +58
Registered:: 02/15/07

Posts: 2097
By: Anonymous: alett ()  Jan 14 2009 13:52 pm  

That did it!
Fixed

T Laughing Out Loud hank you for your quick response! You guys are the best

5 posts :: Page 1 of 1
All times are CDT. The time is now 02:43 pm.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic w/ New Post Sticky Topic w/ New Post
Locked Topic w/ New Post Locked Topic w/ New Post