glFusion Wiki

Site Tools


glfusion:requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
glfusion:requirements [2011/03/14 07:29]
Mark [System Requirements]
glfusion:requirements [2015/10/31 16:11] (current)
Mark
Line 1: Line 1:
 ====== System Requirements ====== ====== System Requirements ======
-To successfully install and use glFusion you must have a fully operational web server, a database, and the server side scripting language PHP.  glFusion is developed and tested primarily on the Apache web server version 2.x, but it should run on any modern web server. ​ glFusion has been successfully installed and is running on other web servers including ​Zeus, Lighttpd, and Microsoft IIS+To successfully install and use glFusion you must have a fully operational web server, a database, and the server side scripting language PHP.  glFusion is developed and tested primarily on the Apache web server version 2.x, but it should run on any modern web server. ​ glFusion has been successfully installed and is running on other web servers including ​Nginx, Lighttpd, and Microsoft IIS.
- +
-glFusion still supports PHP v4.x, but the PHP Foundation has already announced the end of life of the v4.x branch. ​ Using PHP v5.x series is a better long term choice. ​ Currently, the Web Services feature of glFusion requires PHP 5.  If you are running PHP v4.x, Web Services will be automatically disabled.+
  
 glFusion supports a MySQL database. glFusion supports a MySQL database.
Line 9: Line 7:
 **Minimum Requirements** **Minimum Requirements**
 ^Software ​ ^Requirement ​ ^Minimum Recommended ​ ^Web Site  ^ ^Software ​ ^Requirement ​ ^Minimum Recommended ​ ^Web Site  ^
-|PHP  |4.3.10  |5.2.x  |http://​www.php.net ​ | +|PHP  |5.3. |5.4.x  |http://​www.php.net ​ | 
-|MySQL ​ |4.0.18  ​|5.2.x ​ |http://​www.mysql.org ​ |+|MySQL ​ |5.0. ​|5.2.x ​ |http://​www.mysql.org ​ |
 |Apache ​ |1.3.x ​ |2.2 series ​ |http://​www.apache.org ​ | |Apache ​ |1.3.x ​ |2.2 series ​ |http://​www.apache.org ​ |
  
-<note important>​ 
-The glFusion v1.1.x series will be the last release of glFusion to support PHP4. All future releases of glFusion will require PHP v5. 
-</​note>​ 
  
 Your server or hosting environment must have the following items available for you to install and run glFusion. Your server or hosting environment must have the following items available for you to install and run glFusion.
  
-  * Web Server (Apache, Zeus, lighttpd, Microsoft IIS, etc.) +  * Web Server (Apache, Nginx, Zeus, lighttpd, Microsoft IIS, etc.) 
-  * PHP v4.3.0 or higher +  * PHP v5.3.0 or higher 
-  * MySQL v4.0.18+  * MySQL v5.0.1
  
 ====== General Requirements ====== ====== General Requirements ======
  
-glFusion is designed where many of the files should reside outside of the publically available ​web root area. All core functions of the website are stored outside of the public web directory completely inaccessible to web visitors. This makes the “attack surface” of the website extremely small.+glFusion is designed where many of the files should reside outside of the open web root area. All core functions of the website are stored outside of the public web directory completely inaccessible to web visitors. This makes the “attack surface” of the website extremely small.
  
 glFusion can run with a host that **does not** allow access to the directory above the web root, but the preferred environment will allow you to properly host these files in a private, non-public directory. glFusion can run with a host that **does not** allow access to the directory above the web root, but the preferred environment will allow you to properly host these files in a private, non-public directory.
glfusion/requirements.1300105764.txt.gz · Last modified: 2015/07/11 17:21 (external edit)