Forum Index >  glFusion >  glFusion Support New Topic Post Reply
 User doesnt see he is logged in and dont get log in rights.
   |  Printable Version
By: Anonymous: Marsjak ()  Dec 12 2008 14:09 pm (Read 693 times)  
Anonymous: Marsjak

I think I have some cache or refresh problem on 1.0.2 glfushion website.

I myself get sometimes 'old' view after I am logged out and I get to see I am still logged in....

But some users report that after they log in they dont get to view a "logged in" page.

I can see ( and user-list also shows) that they are logged in because I can see their name in Who's Online list.

But they get threatend as not logged in aswell... so when they go to foum they cant see parts of forum that is for special logged in members....

It isn't that ALL have this problem just a few.


What can be source(s) of this problem ?


       
  Quote
By: Mark (offline)  Dec 12 2008 14:25 pm  
Mark

The first place to look is in the configuration screen at the cookie settings (under the Miscellaneous heading). Cookie Path and Cookie Domain are the importation ones to check. Generally Cookie Path should be / and cookie domain should be blank. Double check what you have there and let me know.

Thanks!
Mark

Forum Admin
Admin

Group Comfort
Level:
: +110

Registered: 10/21/05
Posts: 6333
Location: The Great State of
Texas

Profile      
  Quote
By: Anonymous: marsjak ()  Dec 12 2008 16:12 pm  
Anonymous: marsjak

Checked : the / and blank.


       
  Quote
By: Mark (offline)  Dec 12 2008 16:15 pm  
Mark

OK, is your web site's URL like http://www.yoursitehere.com/ or it is a sub-domain like http://www.yoursitehere.com/someotherstuff/ ?

Forum Admin
Admin

Group Comfort
Level:
: +110

Registered: 10/21/05
Posts: 6333
Location: The Great State of
Texas

Profile      
  Quote
By: Anonymous: Marsjak ()  Dec 12 2008 16:44 pm  
Anonymous: Marsjak

No subs. Most you get is like a .com/index.php?msg=8 or plugins.


       
  Quote
By: Geiss (offline)  Dec 12 2008 16:54 pm  
Geiss

It isn't that ALL have this problem just a few.



Do these users have cookies disabled in their browsers? What browsers are they using to access the site?

Thx!

Eric


Forum Active Member
Active Member

Group Comfort
Level:
: +58

Registered: 02/15/07
Posts: 2097
Location: Boise, Idaho

Profile Email Website  
  Quote
By: Anonymous: Marsjak ()  Dec 12 2008 17:40 pm  
Anonymous: Marsjak

I use Firefox and IE7. And log-in always goes ok.

As admin I have this IE6 version for layout checks...

So I just used IE6 and I logged in with me ordinairy user acccount and gues what ?

I see a registered user online ( no names are shown to public..thats normal but I supposed to be logged in.....)

So the page tell me I am NOT logged in. I see log in block and all.

I know I am that registered user online.

Page address : http://www.xxxxxxx.com/index.php

So I open IE7 and log in with admin account.

Ok page after log in and I even see the name of my user account.

Same page address : http://www.xxxxxxx.com/index.php


And indeed, with IE6 ( although me as admin see me as user is logged in) me the user doesnt see the log-in only part of forum......


So what can be done about this?


       
  Quote
New Topic Post Reply


 All times are CDT. The time is now 10:51 pm.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic w/ New Post Sticky Topic w/ New Post
Locked Topic w/ New Post Locked Topic w/ New Post
View Anonymous Posts 
Able to Post 
HTML Allowed 
Censored Content